Альт Терминал Школьный 5. Проблемы.

Изображение пользователя den2007.

Привезли наконец компьютер для терминального сервера.
Решил на днях поставить, только что скачанный Альт Терминал Школьный 5.
И ...
... первые проблемы появились сразу же при установке.

При установке, в самом конце копирования пакетов, перед сохранением настроек появляется сообщение о критической ошибке, что не удаётся прочитать пакет java, хотя вроде бы и запустился, но ltsp не работает,
Ладно думаю может диск, или образ битый, проверил диски, все рабочее.
Давай повторно ставить, в безопасном режиме, снова критическая ошибка только на другом пакете.
День рабочий закончился пошёл домой, дома поставил в минимальной версии на виртуальную машину, вроде бы установился без проблем.
Пришёл на работу и думаю ....

В общем, путём размышлений и поиска в интернет пришёл к выводу, что связано с размером оперативной памяти, а её размер на компьютере 8Гб.
В общем в загрузчике прописал mem=1000М, и установка прошла без проблем, потом параметр убрал.
Но как оказалось это были цветочки.

Сначала проверил все вроде работает и LTSP, старый ноутбук стал просто летать.

Но как то мало приложений в меню, потом подумалось, а вроде и образование галочку ставил,а пункта всего два, открыл synaptic, а все установлено,

вручную запустить из консоли можно, прописав полный путь, но все на английском. В общем пришел к выводу что-те программы,которые с названиями пакетов kde4, в меню отсутствуют, хотя вручную можно было бы привести меню в норму, но что делать с русификацией?

В общем что-то не так, сижу и читаю документацию по KDE.

Кто-то скажет чего мучиться, ставь терминал 4, с радостью бы, но там другие проблемы.

В общем, может кто сталкивался c подобным?

Ответ от Михаила Шигорина

Он собирал это сервер

"сообщение о критической ошибке, что не удаётся прочитать пакет java"
-- это всё-таки почти однозначно битые ISO/болванка/привод, просьба
пересинхронизировать rsync или bittorrent и попробовать другие
писалку/читалку.

У den2007 получилась битая инсталяция, судить по которой не стоит.

Хорошо бы подробности по железу -- платформу/чипсет хотя бы.

-- ---- WBR, Michael Shigorin ------ Linux.Kiev http://www.linux.kiev.ua/

Добавлю от себя - ошибка на 8 гб оперативы проявляется и на других дистрибутивах.

Изображение пользователя den2007.

Насчет железа

Материнская плата
MB Gigabyte GA-EP43T-UD3L

Процессор
Intel Core 2 Quad 2.83G/1333MHz/6M

озу
4 планки Kingston KVR1333D3N9/2G

два жестких диска 1.5 Тб Seagate Barracuda 7200.11
SATA-II, 7200 об/мин, Кэш 32Mb, p/n ST31500341AS

Конечно проблемы с инсталляцией могли быть и с "битые ISO/болванка/привод", но проблема с меню не у меня одного. Образ качал wget с http-сервера, торренты нет смысла использовать скорость более 128 кбит/c все равно не будет(ограничение провайдера), записывал в К3B с проверкой и сверял перед записью MD5.
На том приводе терминального сервера тоже уже и записывал и диски копировал, естественно после установки, не было сбоев, впрочем глюки с инсталляторами в дистрибутивах частеньках встречаются, многие помнят одну из федор с бажным инсталлятором.

А дома все не найду времени и денег глючный привод поменять, не в линуксе, ни в windows не работает на запись DVD, только болванки портит при закрытии сессии, читает любые диски нормально, cd тоже пишет нормально.
Причем смена прошивки привода не помогла, видно что-то аппаратное, так что не привыкать к разным сбоям, насмотрелся уже на всякое.

Изображение пользователя den2007.

Gcompris

установил, и симулятор электрических процессов не работает.
просто установите пакет gnucap и все.
Странно конечно, что такое отношение разработчиков к данному дистрибутиву, так как баги серьезные в дистрибутиве, и недостающие пакеты можно было бы вложить в дистрибутив.

Изображение пользователя den2007.

Решение проблем.

Если есть проблема с установкой.
Что касается проблем установки, при загрузке выбрать Установка в безопасном режиме в строке параметров загрузчика записать mem=900М (число должно быть меньше чем объем озу, в моем случае ОЗУ 8гб, а 900М поставлено специально, иначе установка ни разу до конца не дошла) только не забудьте стереть параметр загрузчика после установки, это можно сделать в центре управления системой, пункт загрузчик.
При выборе наборов пакетов оставить только документацию, остальное установите вручную, если система установится, если все же выскочила критическая ошибка жмите далее, если появились формы меню хорошо, нет значит в bugzillа пишите, или попробуйте снова.
Сразу после входа в сеанс KDE, выходим из APT-indicator, в системном лотке возле часов(не вздумайте автоматически обновлять пока систему, иначе могут быть серьезные проблемы), ставим диск с Терминалом, запускаем консоль с правами рута и вводим
apt-get check

смотрим вывод, если есть ошибки, то надо удовлетворить зависимости, у меня отсутствовала библиотека libxml2, просто запускаем Synaptic ищем и устанавливаем пакет с именем библиотеки.

Вот вроде бы с установкой все.

Теперь решаем проблему с меню.
Все проблемы с меню связаны с переменными системы и KDE.

запускаем консоль с правами рута.

собственно решаем проблему с меню.
cd /etc/profile.d
mcedit shared-mime-info.sh

в открывшемся mc изменяем строку на
export XDG_DATA_DIRS="/usr/share:/var/cache:/usr/share/kde4"
сохраняем при выходе F10

cd /etc/profile.d
mcedit shared-mime-info.сsh
в открывшемся mc изменяем строку на
setenv XDG_DATA_DIRS="/usr/share:/var/cache:/usr/share/kde4"
сохраняем при выходе F10

проблему с меню то решили, а программы из меню не запускаются,
снова дело в переменной на этот раз в PATH.

cd /etc/profile.d
touch kde.sh
chmod +x kde.sh
mcedit kde.sh

в открывшемся mc записываем две строки
export PATH="/usr/lib/kde4/bin:$PATH"
export KDEDIRS="/usr/share/kde4"
сохраняем при выходе F10

все бы хорошо, но с русским языком проблема во многих приложениях.
подключаем сетевые репозитории alt.
в рутовой консоли
apt-get update
apt-get install kde4-i18n-ru
возможно в некоторых приложениях надо будет выбрать язык вручную.

Выходим из сеанса KDE, и снова заходим.

Отключаем сетевые репозитории.
Снова обновляем информацию о пакетах, с помощью
apt-get update
или Synaptic
и устанавливаем необходимые приложения с диска.

После этого можно на постоянно подключить сетевые репозитории установить дополнительные программы и обновить систему.
Удачной работы.

Изображение пользователя wecheslaw.

Сходите на форум альта

Там давно висит подобная тема. Не помню только нашлось ли решение.

Изображение пользователя den2007.

спасибо за ответ

Я сходил посмотрел, но нужной информации мне не нашел, кроме совета стереть профиль.
Хотя благодаря форуму Gentoo, я нашел решение проблемы с меню, проблема с установкой осталась, но не актуальна, так как система поставлена обходными путями, проблема с русским языком решается еще проще.

Изображение пользователя wecheslaw.

Думаю проблема с установкой не глобальная

По опыту использоваться четвертого терминала могу сказать, что эта проблема тоже имелась. Здесь многое зависит от того какое железо используется. Хотя когда комп покупался специально под терминальный сервер это очень неприятно. Я четверку так и не смог поставить на наиболее подходивший по мощности компьютер, пришлось ставить на более слабый.

Изображение пользователя den2007.

Может быть

но меня смущает тот факт, что я пробовал устанавливать этот дистрибутив уже на многих машинах и в большинстве случаев Synaptic и apt-get выдают одинаковые ошибки после установки пакетов, хотя пакеты вроде бы устанавливаются и ситуация легко лечится запуском
rpm --rebuiddb

А комп и сетевой коммутатор покупались под терминальный сервер.

В общем терминальный сервер стоит и работает, хотя ввод в эксплуатацию только с первых чисел июня, предстоит сделать еще много, так как многие компьютеры не поддерживают загрузку с сети.